WAVE 7 - Das Programm zur Datenerfassung der öffentlichen Wasserversorgung

Sächsisches Landesamt für Umwelt, Landwirtschaft und Geologie

WAVE 7 - Grundlagen und Vorbereitung zur Installation

Das Programm WAVE 7 ist eine Neuprogrammierung des Programms WAVE 2008 mit Zugriff auf eine zentrale Datenbank im LfULG, wobei Datenbankstruktur, Schnittstellen, Bedienungsoberfläche und Funktionalität der Vorgängerversion weitgehend beibehalten wurden. Voraussetzung zum Betrieb von WAVE 7 ist eine Anbindung des Client-Rechners an eine Datenfernübertragung mittels Internet, KDN / Infohighway Sachsen oder des Intranet des LfULG. Das System besteht aus den drei Komponenten (s. Abbildung unten)

  • Datenbank SQL-Server 2012, .NET-XML-Webservice, Client-Anwendung WAVE 7

  

 

Das Client-Programm ist eine Windows-Forms Anwendung, programmiert in VB.NET und ist für alle Anwender kostenfrei verfügbar. Die Installation erfolgt mittels Click-Once-Technologie. Das richtige Anwenden dieser Technologie gestattet es, automatisch (ohne Hilfe eines IT-Administrators) Updates einzuspielen. Systemvoraussetzung für den Client-Rechner ist ein Windows Betriebssystem, auch als Terminal-Server-Version. Die Installation des Programms erfordert grundsätzlich keine Anpassung des jeweils vorhandenen Windows-Betriebssystems des Rechners/Arbeitsplatzes, wenn dieser einen aktuellen Updatestand und ein installiertes .NET Framework 4.7.2 (aktuell für Betriebssysteme ab Windows 7) hat.

Für die Darstellung von Berichten werden noch zusätzliche Komponenten des Microsoft Report Viewer benötigt, die vorher mit Administratorrechten zu installieren sind. Die Pakete sind auf dem Webserver der Seite www.wave7.de in der passenden Version verfügbar (Links siehe unten).

BITTE BEACHTEN:
Ab der Version 2.6.0.0 wird das TLS - Transportverschlüsselungsverfahren in der Protokollversion TLS 1.2 verwendet. In Abhängigkeit vom verwendeten Betriebssystem (z. Bsp. Windows Server 2008) oder individuellen Sicherheitseinstellungen muss die Verschlüsselungsmethode erst aktiviert werden.

Ab der Version 2.6.0.0 von WAVE 7 wird zum Drucken der Microsoft Report Viewer 2015 benötigt. Dazu müssen die entsprechende Bibliothek für den Reportviewer Clr-Bib-X64 oder Clr-Bib-X32 (je nach Betriebssystem) und der Microsoft Report Viewer 2015 (Laufzeit) installiert werden. Das Betriebssystem des Windows-Rechners muss mindestens das .NET Framework 4.7.2 enthalten, um mit WAVE 7 und diesem Reportviewer Ausdrucke erzeugen zu können. Die Erstinstallation des Client-Programms muss unbedingt über eine Installationsseite des LfULG erfolgen, die zusätzlichen Komponenten sollten besser über o.g. Links installiert werden.

Für den Betrieb von Wave 7 und das Funktionieren der automatischen Aktualisierung ist es erforderlich, dass der jeweilige Nutzer mit seinen Rechten am Computer die ClickOnce-Installation von der jeweiligen URL, welche das LfULG bereitstellt, selbst ausführt. Wird das nicht beachtet, funktioniert die automatische Aktualisierung nicht! Seit dem 10.02.2022 ist die Installation nur noch bei vorhandenem .NET 4.7.2 auf dem Zielsystem möglich!

Die Erstinstallation des Client-Programms kann nur über einen bereitgestellten Link vom LfULG erfolgen.

Für den Betrieb von WAVE 7 und das Funktionieren der automatischen Aktualisierung ist es erforderlich, dass der jeweilige Nutzer mit seinen Rechten am Computer die ClickOnce-Installation von der jeweiligen URL, welche das LfULG bereitstellt, selbst ausführt. Wird das nicht beachtet, funktioniert die automatische Aktualisierung nicht!

Bei der Erstinstallation des Programms erfolgt ein Eintrag im Windows-Startmenü, über den die folgenden Programmstarts auszuführen sind. Bei jedem weiteren Programmstart wird das Vorliegen eines Updates der Client-Anwendung auf dem LfULG-Server geprüft, das dann ggfls. automatisch ausgeführt wird.